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What is FLEx?

• An XML database to help with managing linguistic (and
anthropological) data

• Primarily designed to help linguistic field workers document and
analyse languages

• Will be useful for anyone working with a text corpus, and/or
extensive interlinearisation
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What can FLEx do?

• Organise a corpus of texts

• Create a lexical database from your texts
• Lexical database can ultimately be used to create a dictionary

• Analyse your texts from your lexical database

• Link to audio files

• Import/export data to other software (e.g. Elan, Lexus, etc)

• Record anthroplogical field notes
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What can’t FLEx do?

• The original linguistic analysis!
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Installing the software

• FieldWorks can be downloaded for free from
http://fieldworks.sil.org/download/

• Latest stable release:
• Windows: FieldWorks 8.1.2
• Linux: FieldWorks 8.0.5 (beta)
• Mac: FieldWorks does not currently support any Mac OS:

• FieldWorks will work with Bootcamp, or on a Windows emulator
(Parallels, VMware Fusion, Virtual Box).

• Fieldworks does not currently work with Wine.
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In today’s workshop, you will learn how to....

• Start a new project

• Enter data into a corpus

• Interlinearise the data from the vernacular language using an
analysis language

• Create and manage a lexicon

• Enter information about the grammar of the vernacular language

• Use the semi-automatic parser
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Some terminology:

• Vernacular language: The language you are studying or analysing.
• Today our vernacular languages will be Swahili and a closely-related

(and made-up) language, Ilihaws

• Analysis language: The language you are using to describe the
vernacular language.

• Today our analysis language will be English
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1. Starting a new project
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Starting a new project

• Start > All programs > FieldWorks 8 > Language Explorer >
Language Explorer

• Click ‘Create a new project’
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New project properties
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New project properties
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New project properties
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New project properties
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New project properties
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The FLEx window
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The FLEx window
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2. Entering our first data
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Entering our first data

• We’ve been out in the field, collecting data from speakers of Swahili.

• So far, we have the following sentences:

(1) ugari unafika ‘The cars are arriving.’

(2) igari idogo itafika ‘The little car will arrive.’

(3) mutafika ‘You (pl.) will arrive.’

(4) tumefika ‘We have arrived.’

(5) kikombe kizuri kilifika ‘The nice cup arrived.’

• We want to enter these sentences and the translations into our
corpus.
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Entering our first data

• Give your text a title

• Transcribe the data in the ‘Baseline’ tab:
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Entering our first data

• Translate the data in the ‘Gloss’ tab:
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The data fully transcribed
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The data fully translated
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Glossing words

• Type the word gloss under the appropriate word in the Word Gloss
field

• Choose a part of speech by clicking on the little arrow in the
Word Cat. field

• It’s to you how much detail you put in at this stage - this is where
to record your first impressions on the data.
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Adding a new part of speech
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Adding a new part of speech
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Entering our first data

• Our first data, transcribed, translated, and with a first gloss:
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3. Interlinearisation
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Interlinearisation

• Here’s a data set we prepared earlier!

• ‘Ilihaws’
• Closely related to Swahili....
• ...and also very made-up.

• File > Open > Select the database ‘Ilihaws’
• We won’t be working with the Swahili database again, so you can

close it if you like. It will have automatically saved to your computer.
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Interlinearisation

• In the ’Texts & Words’ window, click on the ’Analyze’ tab:
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Interlinearisation

• On the basis of our analysis of Ilihaws, we want give sentence 2 the
following gloss:

/umefika/
u-me-fika
2.sg-perfect-arrive

‘You (sg.) have arrived’
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Interlinearisation

• Creating morpheme breaks in the Morphemes field:
• Stems: [aa ] : stem; [*aa ] : bound stem
• Affixes: [a- ] : prefix; [ -a] : suffix; [ -a- ] : infix
• Clitics: [a= ] : proclitic; [ =a] : enclitic
• Other: [ =a= ] : simulfix; [ ˜a˜] : suprafix
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Interlinearisation

• Creating a new entry for a root or stem:

1. Click the little arrow on the Lex. Entries field under /fika/
2. Select ’Create New Entry’
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Interlinearisation

• Creating a new entry for a root or stem:

3. From the drop-down menu ‘Morpheme Type’, select ‘Root’
4. From the drop-down menu ‘Category’, select ‘Verb’
5. Enter the gloss ‘arrive’ in the ‘Gloss’ field
6. Click ‘Create’
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Interlinearisation
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Interlinearisation

• Creating a new entry for an affix:

1. Click the little arrow on the Lex. Entries field under /me-/
2. Select ’Create New Entry’
3. Check that the ’Morpheme Type’ is ‘prefix-’ (this should be

automatic)
4. From the drop-down menu ‘Affix Type’, select ‘Inflectional’
5. From the drop-down menu ‘Attaches to Category’, select ‘Verb’
6. Enter the gloss for the affix, ’perfect’
7. Click ‘Create’
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Interlinearisation
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Interlinearisation

• Creating a new entry for an affix using the Inflectional Affix Gloss
Builder:

1. Click the little arrow on the Lex. Entries field under /u-/
2. Select ’Create New Entry’
3. Check the ’Morpheme Type’ is ‘prefix-’ (this should be automatic)
4. From the drop-down menu ‘Affix Type’, select ‘Inflectional’
5. From the drop-down menu ‘Attaches to Category’, select ‘Verb’
6. Click on ‘Inflectional Affix Gloss Builder’ (next to the Gloss field)
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Interlinearisation
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Interlinearisation

• Creating a new entry for an affix using the Inflectional Affix Gloss
Builder:

7. Verb-related > Agreement > Subject agreement > Person >
Second person > Click ‘Insert’
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Interlinearisation

• Creating a new entry for an affix using the Inflectional Affix Gloss
Builder:

8. Verb-related > Agreement > Subject agreement > Number >
Singular number > Click ‘Insert’

9. When you’re happy with the gloss given in the top field, click ‘Accept
Gloss’, and then ‘Create’ on the ‘New Entry’ window
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Interlinearisation

• Your fully glossed word /umefika/ should now look like this:



Starting a new project Entering our first data Interlinearisation The Lexicon Agreement Parsing

Interlinearisation

• There are two options in the bottom right corner:

• Click ‘Approve Thoughout this Text’.
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Gloss these sentences

• Use the Interlinear Affix Gloss Builder where relevant

7 /mutafika/
mu-ta-fika
2pl-fut-arrive

‘You (pl.) will arrive’

8 /utaaNguka/
u-ta-aNguka
2sg-fut-fall

‘You (sg.) will fall’

11 /tutakufa/
tu-ta-kufa
1pl-fut-die

‘We will die’

13 /nimefika/
ni-me-fika
1sg-perfect-arrive

‘I have arrived’

16 /tumefika/
tu-me-fika
1pl-perfect-arrive

‘We have arrived’

19 /unakufa/
u-na-kufa
2sg-prs-die

‘You are dying’
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Allomorphs

• The prefix /me-/, which we have glossed as ‘perfect’, has an
allomorph /men-/ when preceding a vowel:

1. In the Texts and Words view on the Analyze tab, scroll down to
sentence 21. We want to gloss this sentence as:

/umenaNguka/
u-men-aNguka
2.sg-perfect-fall

‘You have fallen.’

2. Enter the morpheme breaks
• FLEx should automatically gloss /u-/ as ‘2.sg’, and /aNguka/ as ‘fall’
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Allomorphs

• Entering an allomorph:

3. Click on the small arrow in the Lex. Gloss field under /men-/, and
select ‘Allomorph of...’
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Allomorphs

• Entering an allomorph:

4. In the pop-up window, search for /me-/. Select the prefix and click
‘Add allomorph’
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Allomorphs

• Entering an allomorph:
5. It is possible to add the environments that the allomorph occurs in, in

the Lexicon view...
• ...but we won’t go into that today.
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4. The Lexicon
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Admiring your lexicon

• Switch to Lexicon view by clicking on the ‘Lexicon’ tab
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Admiring your lexicon
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Creating a new lexical entry

• Insert > Entry

• or click on the red hexagon with a green plus sign in the toolbar

• The ‘New Entry’ pop-up window is the same as the one we saw
before in ‘Texts and Words’:
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Creating a new lexical entry

• Add the following items to your lexicon:

Lexeme Gloss: Morpheme Category:
form: type:
gari car root noun
ti tree root noun
tabu book root noun
kombe cup root noun
toto child root noun
zuri nice root adjective
dogo little root adjective
kubwa big root adjective
cafu dirty root adjective
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Sorting your data and finding a lexical entry

• Your data is by default sorted alphabetically by headword
• You can sort by any of the columns in the ‘Entries’ browse pane by

clicking on the header.

• To find a lexical entry, you can also use the search function:
• Edit > Find lexical entry
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Deleting a lexical entry

• Deleting a lexical entry is easy: Select the entry in the ‘Entries’
browse pane, and either

• click on the red cross in the tool bar
• or right-click the entry and select ‘Delete selected entry’
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5. Agreement
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Agreement

• Ilihaws is a Bantu language, and has a rich system of gender
agreement.

• We are going to set up a template so that FLEx will automatically
parse this agreement.

• Switch to Grammar view by clicking on the ‘Grammar’ tab
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Setting up an affix template

1. First, we need to set up an affix template to tell FLEx the shape of
a fully inflected word.

2. For nouns, we know the template is:

classifier-stem

3. Select ‘Category Edit’ from the ‘Grammar’ pane; select ‘Noun’; then
click ‘Insert Affix Template’
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Setting up an affix template
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Setting up an affix template

4. Click on the small blue arrow in a circle next to ‘STEM’, and select
‘Insert slot before STEM’
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Setting up an affix template

5. Click on ‘Add an obligatory slot to Noun’
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Setting up an affix template

6. Give the slot a name
• Here, we’ll go with ‘class-’
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Entering an inflection feature

• We have just told FLEx what the template of an inflected noun is in
Ilihaws. Now we need to tell FLEx the functions of the affixes that
can attach to a noun.

1. On the left side of the window, select ‘Inflection Features’, and then
Insert > Feature
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Entering an inflection feature
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Entering an inflection feature

2. noun-related > noun agreement > Bantu noun class > Select
Gender 1/2, Gender 3/4, Gender 5/6, and Gender 7/8 > Add
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Entering an inflectional paradigm

• Now we have to tell FLEx the forms of the different nominal
classifiers.

1. Navigate back to the noun template we created (category edit >
noun)

2. Right-click on the small blue arrow next to ‘class-’ in the affix
template. Select ‘Add inflectional affix(es) to class’
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Entering an inflectional paradigm
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Entering an inflectional paradigm

3. In the pop-up window, you can choose from inflectional affixes that
are already in your lexicon. As we haven’t added any nominal
classifiers to our lexicon yet, we will have to create entries for them.

4. Click ‘Create new inflectional affix’
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Entering an inflectional paradigm

• The first classifier affix that we want to enter is /m-/, which
attaches to singular class 1/2 nouns:

5. Enter the form of the prefix, and then use the Inflectional Affix Gloss
Builder to give it a gloss

• noun-related > noun agreement > Bantu noun class > Gender 1/2
• noun-related > noun agreement > number > singular number

6. When you’re happy with the new entry, click ‘Create’.
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Entering an inflectional paradigm
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Entering an inflectional paradigm

• Enter the rest of the paradigm for nominal classifiers:

Form Gloss
wa- 1/2.pl
ki- 3/4.sg
vi- 3/4.pl
m- 5/6.sg
mi- 5/6.pl
i- 7/8.sg
u- 7/8.pl
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Entering an inflectional paradigm
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Assigning an inflectional feature to a root

• Finally, we need to tell FLEx what gender the root nouns in our
corpus are.

1. Return to Lexicon view
2. Find the nouns in your lexicon

• HINT: remember you can sort your database by grammatical
information

3. Select the root /kombe/ ‘cup’ for editing (gender 3/4)
4. In the Entry pane on the right, click ‘Show hidden fields’
5. Scroll down to Grammatical Info Details and click on the three

small dots next to the ‘Inflectional Features’ field.
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Assigning an inflectional feature to a root
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Assigning an inflectional feature to a root

6. Select ‘Gender 3/4’, and click OK
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Assigning an inflectional feature to a root

• Repeat for the other nouns in your corpus:

Root Gloss Gender
gari car 7/8
tabu book 3/4
ti tree 5/6
toto child 1/2
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Adjectival morphology

• Now follow the same steps to create this affix template for
adjectives:

agreement- STEM

m- 1/2.sg
wa- 1/2.pl
ki- 3/4.sg
vi- 3/4.pl
m- 5/6.sg
mi- 5/6.pl
i- 7/8.sg
u- 7/8.pl
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Adjectival morphology

• Note adjective agreement prefixes are the same form as the nominal
classifiers, so you in the ‘Choose Inflectional Affixes’ window, you
can simply select the forms that have already been entered.
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Verbal morphology

• Now create this affix template for verbs:

subject
agreement-

tense- STEM

a- 1/2.sg me- perfect
wa- 1/2.pl li- pst
ki- 3/4.sg ta- fut
vi- 3/4.pl na- prs
u- 5/6.sg
i- 5/6.pl
i- 7/8.sg
u- 7/8.pl
ni- 1.sg
u- 2.sg
tu- 1.pl
mu- 2.pl
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6. Parsing
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Using the parser

• Now you’re ready to see the semi-automated interlinearisation at
work!

1. Switch back to Texts and Words view, and select the Analyze tab.
2. In the toolbar, select Parser > Parse all words
3. Sit back and watch what happens...
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Using the parser
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Using the parser

...fun, huh?!
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